Multiplay Labs

tech hits and tips from Multiplay

Archive for June 1st, 2011

“version” perl Module Upgrade on SFU results in broken perl!

without comments

For those of you who use SFU, a useful POSIX layer thats freely available for Windows that want to update / install new perl modules using CPAN, be aware that the updated the “version” module can lead to a broken perl install. The resulting symptoms are that perl commands hang doing nothing. The cause of this is that you end up with two “version” module folders, one lower case “version” and one upper-case “Version”.

The fix is simply to remove the old “Version” folder from /usr/local/lib/perl5/site_perl//x86-interix-thread-multi/auto/

Written by Dilbert

June 1st, 2011 at 7:56 pm

Posted in Perl